Browse lento

SQL, mySQL, postgreSQL y otros motores
Responder
tomkar
Novato
Mensajes: 46
Registrado: Mié Abr 06, 2011 10:20 pm
Contactar:

Browse lento

Mensaje por tomkar » Lun May 09, 2011 11:51 pm

estoy con la emigracion a MYSQL y en el browse se me pone lento para cargar. al agregarle una tabla relacionada

que sera?


Avatar de Usuario
Mauricio
Desarrollador de Clarion
Mensajes: 1055
Registrado: Dom Feb 06, 2011 9:34 am
Ubicación: España
Contactar:

Re: Browse lento

Mensaje por Mauricio » Mar May 10, 2011 6:37 am

Te fijaste en el trace para ver qué consulta le está enviando al motor?
Mauricio, básicamente usando Clarion 6.3
www.tdcsoftware.com y www.clarioneros.com/blog

tomkar
Novato
Mensajes: 46
Registrado: Mié Abr 06, 2011 10:20 pm
Contactar:

Re: Browse lento

Mensaje por tomkar » Mié May 11, 2011 3:57 pm

Mauricio escribió:Te fijaste en el trace para ver qué consulta le está enviando al motor?
pues es una simple consulta, lo raro es que si le quito la tabla relacionada si jala bien. Pero cuando se agrego se alenta bastante!!!!

Avatar de Usuario
Mauricio
Desarrollador de Clarion
Mensajes: 1055
Registrado: Dom Feb 06, 2011 9:34 am
Ubicación: España
Contactar:

Re: Browse lento

Mensaje por Mauricio » Mié May 11, 2011 4:46 pm

Por eso te digo que te fijes en el trace y ejecutes luego ese trace en algún administrador de consultas para ver dónde está el problema.
Mauricio, básicamente usando Clarion 6.3
www.tdcsoftware.com y www.clarioneros.com/blog

tomkar
Novato
Mensajes: 46
Registrado: Mié Abr 06, 2011 10:20 pm
Contactar:

Re: Browse lento

Mensaje por tomkar » Jue May 12, 2011 6:21 pm

Mauricio escribió:Por eso te digo que te fijes en el trace y ejecutes luego ese trace en algún administrador de consultas para ver dónde está el problema.
Cual me recomiendas?

Saludoss

Avatar de Usuario
DanielRuzo
Al nivel de RZ
Mensajes: 124
Registrado: Dom Feb 06, 2011 7:45 pm
Ubicación: Uruguay
Contactar:

Re: Browse lento

Mensaje por DanielRuzo » Jue May 12, 2011 6:27 pm

Puede ser que con sólo ver el trace ya te des cuenta del problema. mySQL tiene un problemas con el paginado, por lo que si la tabla es muy grande te va a resultar lentísimo. No creo que sea tu caso, porque se pone lento recién cuando agregás una tabla secundaria. En este caso, podría ser por ejemplo que el driver no esté devolviendo bien el valor para el NESTING, y esté enviando una consulta al motor por cada registro para obtener la tabla relacionada, en lugar de traer todo en una sola consulta. Esto tiene solución, pero tendrías que asegurarte viendo en el TRACE qué consultas está enviando al motor.
¡Saludos!

Daniel Ruzo
www.amazingGUI.com

Yo creo en la reencarnación:
antes tenía una vida y ahora soy programador

tomkar
Novato
Mensajes: 46
Registrado: Mié Abr 06, 2011 10:20 pm
Contactar:

Re: Browse lento

Mensaje por tomkar » Mar May 17, 2011 5:23 pm

DanielRuzo escribió:Puede ser que con sólo ver el trace ya te des cuenta del problema. mySQL tiene un problemas con el paginado, por lo que si la tabla es muy grande te va a resultar lentísimo. No creo que sea tu caso, porque se pone lento recién cuando agregás una tabla secundaria. En este caso, podría ser por ejemplo que el driver no esté devolviendo bien el valor para el NESTING, y esté enviando una consulta al motor por cada registro para obtener la tabla relacionada, en lugar de traer todo en una sola consulta. Esto tiene solución, pero tendrías que asegurarte viendo en el TRACE qué consultas está enviando al motor.
Woww no se que paso que se soluciono solo quite la tabla relacionada, lo corry y no funciono, se la volvio agregar, por arte de magia ya me funciono bien!!!!!!!

que pasaria!!!!


Responder

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado